02/13/21 18:56:53

Instalarea unei versiuni actuale de VLC pe o distribuție mai veche de Ubuntu sau derivate


Dacă folosiți o variantă LTS de Ubuntu (18.04 sau 20.04), sau dacă folosiți Linux Mint, Linux Lite, Voyager, sau o altă distribuție bazată pe Ubuntu, atunci aveți un player VLC cu probleme în ceea ce privește redarea anumitor streamuri. Acest lucru afectează TV-Lite în mod direct, deoarece acesta se bazează pe libVLC pentru a reda canalele TV. Distribuțiile bazate pe Ubuntu 18.04 au inclus VLC 3.0.8, unde lucrurile stau ceva mai bine. Problema apare în cazul Ubuntu 20.04 care  include versiunea 3.0.9, o adevărată „catastrofă” când e cazul de vizualizat streamuri IPTV.
Din fericire există de ceva timp posibilitatea de a trece la o versiune mai nouă datorită unui PPA.

Categorie: General
Postat de: oberon

vlc

PPA-ul de mai jos oferă VLC versiunea 3.0.11, care corectează erorile din versiunile anterioară. La ora la care scriu acest articol, VLC se află la versiunea 3.0.12, dar această versiune a fost scoasă mai mult pentru că adaugă suport pentru a rula pe laptopuri Apple bazate pe noul procesor M1 cu arhitectură ARM.
Acest PPA include de asemenea FFmpeg versiunea 4.2, ce conține codecurile folosite de VLC Acest pachet este necesar pentru distribuțiile bazate pe Ubuntu 18.04. Pentru Ubuntu 20.04, prima comandă din lista următoare este deci opțională

sudo add-apt-repository ppa:savoury1/ffmpeg4
sudo add-apt-repository ppa:savoury1/vlc3
sudo apt-get update

Daccă folosiți TV-Lite, evident, VLC este instalat. Însă, dacă din cine știe ce motiv,  nu aveți VLC instalat, acesta se instalează, evident, cu

sudo apt install vlc